User Tools

Site Tools


tech:psoft:lle_deprecation

Annoying LLE deprecation Messages in Weblogic PIA and Appserver

Appserver

* Edit the Tuxedo Domain's <PS_CFG_HOME>/appserv/<DOMAIN_NAME>/psappsrv.ubx file. * At the bottom of that file there is a section for environment settings. Add a new environment variable

'LLE_DEPRECATION_WARN_LEVEL=NONE'

* Reconfigure and restart the domain.

Weblogic PIA

In PeopleTools 8.54 and beyond Weblogic gives the annoying LLE deprecation message in its log. Link Level Encryption (LLE) is now deprecated in modern versions of Weblogic.

"WARNING: LLE Configuration discovered! Note that LLE has been deprecated. You should upgrade to SSL to secure network links"
  • Edit the file <PIA_HOME>\webserv\<PIA_NAME>\bin\setEnv.bat (windows) or setEnv.sh (Unix)
  • Add the following to the JAVA_OPTIONS (same place where your Heap size is defined Xms Xmx)
-Dtuxedo.jolt.LLEDeprecationWarnLevel=NONE
  • Restart PIA
tech/psoft/lle_deprecation.txt · Last modified: 2024/02/21 19:09 by 127.0.0.1

Except where otherwise noted, content on this wiki is licensed under the following license: Public Domain
Public Domain Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki