User Tools

Site Tools


tech:psoft:install_psoft_on_gentoo

Installing PeopleSoft on Gentoo Linux

General Gentoo Setup:

My USE Flags:

USE=“-doc -kde -qt -postgres -xemacs mmx sse acl usb pam sftplogging bzip2 toolbar menubar tiff caps server”

Portage Commands:

emerge –update –deep –newuse world
emerge -pv depclean
revdep-rebuild –ignore –pretend

Emerging Packages:

emerge –sync
USE=“-doc symlink” emerge gentoo-sources
emerge vim syslog-ng vixie-cron slocate dhcpcd grub usbutils pciutils coldplug gentoolkit ncompress
emerge fluxbox fbdesk mrxvt mozilla-firefox sshfs-fuse xfe openoffice-bin dnsmasq ntp vnc samba
emerge sys-libs/lib-compat

Fixing pam-login shadow emerge blockage:

emerge -C pam-login
emerge -1 shadow

Auto starting fbdesk with fluxbox:

edit ~/.fluxbox/startup
add
mrxvt &
fbdesk &

fbdesk Icons:

Download http://www.ionbox.org/files/gentoo-bubble-icons.tgz
Unzip into /usr/share/pixmaps
Look at ~/kb/.fluxbox/menu for how pixmaps are used
Look at ~/kb/.fluxbox/fbdesk.icons for another example

Using smbmount:

emerge samba
smbmount 192.168.1.2/share /mnt/share -o username=azutshi
smbmount
192.168.1.2/psoft /mnt/psoft -o username=azutshi

PeopleSoft Setup:

Users:

groupadd dba
groupadd psoft
useradd -m -g dba   -G tty,wheel -d /opt/oracle -s /bin/bash oracle
useradd -m -g psoft -G tty,wheel -d /opt/psoft  -s /bin/bash psoft

Limits:

In ~/.bashrc add the following:

ulimit -u 16384 -n 63536 -c unlimited

Mounting PS CD's:

You may have to mount the CDROM below as “root”

mount -t iso9660 -r /dev/cdrom /mnt/cdrom
/mnt/cdrom/setup.linux

Fixing psconfig.sh:

Add the following to psconfig.sh. Note You don't need LD_PRELOAD for PT8.49 but you DO need it for PT8.47

#export LD_PRELOAD=/opt/psoft/fixlib/libstdc++-3-libc6.2-2-2.10.0.so
echo "Set Environment HRDMO89 - /opt/psoft/pt849/hcm890/psconfig.sh"
export ORACLE_HOME=/opt/oracle/product/10.2.0.1
export ORACLE_BASE=/opt/oracle
export ORACLE_SID=HRDMO89
export COBDIR=/opt/microfocus/cobol
export LD_LIBRARY_PATH=/lib:$COBDIR/lib:$ORACLE_HOME/lib
export DISPLAY=:0.0
export PATH=/usr/bin:/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.1.2:$COBDIR/bin:$ORACLE_HOME/bin

also:

echo "release 3" > /etc/redhat-release

Please don't forget to edit PS_HOSTTYPE

PS_HOSTTYPE=redhat-gentoo-ia32; export PS_HOSTTYPE

Linking PSRUN:

Run $PS_HOME/setup/psrun.mak. If you get:

ld: cannot find -lgcc"

edit $COBDIR/etc/cobopt
replace: set GCC_LIB=/usr/lib/gcc-lib/i386-redhat-linux/3.2.3
with: set GCC_LIB=/usr/lib/gcc/i686-pc-linux-gnu/3.4.6
the correct value is gleaned from: /etc/ld.so.conf

to remove the “ld: warning: libclntsh.so.9.0, needed by /opt/psoft/install/bin/libpsora_ansi.so, not found” error:
as oracle:
cd $ORACLE_HOME/lib

ln -s libclntsh.so.10.1  libclntsh.so.9.0

Fixing AppServer Process scheduler __dynamic_cast_2 symbol errors:

download a 2.9.5 libstdc++ rpm from rpmfinder:
ftp://rpmfind.net/linux/redhat/7.3/en/os/i386/RedHat/RPMS/libstdc++-2.96-110.i386.rpm
run rpm2targz against the rpm file.
copy the lib directory to /opt/psoft/azlib:

sprydev /opt/psoft # ls -la azlib
total 432
drwxr-xr-x 2 root  root    4096 Jun 19 10:31 .
drwxr-xr-x 6 psoft psoft   4096 Jun 19 16:42 ..
-r-xr-xr-x 1 root  root  426442 Jun 19 10:31 libstdc++-3-libc6.2-2-2.10.0.so
lrwxrwxrwx 1 root  root      31 Jun 19 10:31 libstdc++-libc6.2-2.so.3 -> libstdc++-3-libc6.2-2-2.10.0.so

add export LD_PRELOAD=/opt/psoft/azlib/libstdc++-3-libc6.2-2-2.10.0.so to psconfig.sh you should be good to go.

Installing Tuxedo 9.1:

See the Tux 9.1 section in Installing BEA Tuxedo on Linux

Fixing "Failure to create message queue":

163150.sprydev!JSH.18327.16384.-2: 06-19-2006: Tuxedo Version 8.1, 32-bit
163150.sprydev!JSH.18327.16384.-2: LIBTUX_CAT:681: ERROR: Failure to create message queue
163150.sprydev!JSH.18327.16384.-2: JOLT_CAT:1088: "ERROR: tpinit() failed, tperrno = 7"
163150.sprydev!JSL.18326.16384.0: JOLT_CAT:1079: "ERROR: Error starting mininum number of handlers"
163150.sprydev!JSL.18326.16384.0: LIBTUX_CAT:250: ERROR: tpsvrinit() failed

Edit /etc/sysctl.conf. We have to mess with the “sem” parameter

kernel.shmall = 2097152
kernel.shmmax = 2147483648
kernel.shmmni = 4096
kernel.msgmni = 1024    //<-------------IMPORTANT!!!!//
kernel.sem = 250 32000 100 128
fs.file-max = 65536
net.ipv4.ip_local_port_range = 1024 65000
net.core.rmem_default = 262144
net.core.rmem_max = 262144
net.core.wmem_default = 262144
net.core.wmem_max = 262144

PeopleTools 8.49 Note

It is not necessary to go through the shenanigans above. In fact, the LD_PRELOAD environment variable should be unset if you are installing PeopleTools 8.49. If you still have it set, You will end up with tuxedo problems such as:

085820.machine-name!PSAPPSRV.6043.1.0: LIBTUX_CAT:476: WARN: Server 99/2: client process 1859: lost message
085820.machine-name!PSAPPSRV.6043.1.0: LIBTUX_CAT:477: WARN: SERVICE=ICPanel    MSG_ID=0    REASON=server died

Fixing "Cannot find or open field table. Maybe FIELDTBLS32 is not set properly"

  • Backup your <PS_HOME>/appserv/DomainName/psappsrv.ubx file.
  • Edit your <PS_HOME>/appserv/DomainName/psappsrv.ubx file and search for FIELDTBLS32. You will find in two places. Change the current value:
FIELDTBLS32=tpadm

to

FIELDTBLS32=jrep.f32,tpadm
  • Search for FLDTBLDIR32, again there are two entries. Change:
FLDTBLDIR32=$TUXDIR/udataobj

to

FLDTBLDIR32={$TUXDIR}/udataobj

Make sure the value above has the / (slash) going in the proper direction for UNIX as the default may be set going the incorrect way.

  • Reconfigure your domain so the psappsrv.ubb file gets updated with this new value.

Weblogic Crashes with "Error Message: Illegal memory access. [54]"

tech/psoft/install_psoft_on_gentoo.txt · Last modified: 2024/02/21 19:09 by 127.0.0.1

Except where otherwise noted, content on this wiki is licensed under the following license: Public Domain
Public Domain Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki